読者です 読者をやめる 読者になる 読者になる

ただの雑記

アラサーエンジニアが適当に書き散らかしてます。

放置プレイをしていたRaspberryPiで遊んでみた。

そこそこ前にRaspberryPi B+を買ったのだけれども、買って動くのを見て満足して
長い間放置していた。

日記に書く事があまりにも無いので、少し触ってみた。

といっても、以下を参考に最新のmonoをインストールして、やったね。 で終わる予定。

blog.shibayan.jp

とはいえさくっと終わらず。

dpkg: 大量のエラーが発生したため、中断します
処理中にエラーが発生しました:
mono-gac
mono-runtime-common
mono-runtime-sgen
mono-runtime
libmono-corlib4.5-cil
libmono-corlib2.0-cil
mono-utils
libmono-security2.0-cil
libmono-system2.0-cil
libmono-posix2.0-cil
libmono-cecil-private-cil
libmono-posix4.0-cil
libmono-system-core4.0-cil
libmono-codecontracts4.0-cil
libmono-compilerservices-symbolwriter4.0-cil
libmono-peapi2.0a-cil
libmono-peapi4.0a-cil
libmono-relaxng4.0-cil
libmono-system-componentmodel-composition4.0-cil
libmono-system-componentmodel-dataannotations4.0-cil
libmono-system-configuration-install4.0-cil
libmono-data-tds4.0-cil
libmono-system-transactions4.0-cil
libmono-system-enterpriseservices4.0-cil
libmono-system-data4.0-cil
libmono-system-runtime-serialization4.0-cil
libmono-system-data-linq4.0-cil
libmono-data-tds2.0-cil
libmono-system-data2.0-cil
libmono-system-numerics4.0-cil
libmono-system-runtime-serialization-formatters-soap4.0-cil
libmono-sqlite4.0-cil
libmono-system-drawing4.0-cil
libmono-system-web-applicationservices4.0-cil
libmono-system-web4.0-cil
libmono-system-web-services4.0-cil
libmono-system-runtime4.0-cil
libmono-system-identitymodel4.0-cil
libmono-system-identitymodel-selectors4.0-cil
libmono-messaging4.0-cil
libmono-accessibility4.0-cil
libmono-webbrowser4.0-cil
libmono-i18n4.0-cil
libmono-i18n-west4.0-cil
libmono-system-windows-forms4.0-cil
libmono-system-messaging4.0-cil
libmono-system-servicemodel4.0a-cil
libmono-system-servicemodel-activation4.0-cil
libmono-sqlite2.0-cil
libmono-messaging2.0-cil
libmono-system-messaging2.0-cil
大量のエラーが発生したため、処理が停止しました。
E: Sub-process /usr/bin/dpkg returned an error code (1)

とりあえずパッケージ類をアップデート
sudo apt-get update
sudo apt-get upgrade

流石に大量にあって、じっくり待つ。 そろそろ眠くなってきた。

そしてまた、大量のエラーで処理が停止。 こうなったら新しいファームでてるだろうと次のコマンドを
sudo rpi-update

アップデートが終わったらリブート
sudo reboot

そしてまたアップデート
sudo apt-get update
sudo apt-get upgrade
結果変わらず。

エラーからmono系があれだなと言うことで一旦削除 sudo apt-get remove mono-complete

が失敗。

そろそろ辛い。
sudo apt-get autoremoveとか試しても変わらないし
とりあえず、一旦終了。
明日以降がんばります。